Skip to content Skip to main navigation Skip to footer

Import Quiz Not working

Welcome to QSM Support Forum. Forums QSM Pro Support Import Quiz Not working

Tagged: 

Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
    Posts
  • #3284
    Tim WTim W
    Participant

    Hi, I am trying to copy a quiz between a production and development site.

    I have the premium addons and these are installed on both sites. See screenshot of plugins. I can successfully export from both sites, but I am unable to import a quiz – this is the first time I have tried to do this. There is no success or error message displayed after selecting the file and, but the quiz does not appear in the list of available quizes.

    I have tried both JSON and CSV formats and have tried simple / small and also larger / more complex quizes without any success.

    I tried re entering the license key, including the premium bundle license key but I cant get it to work. I also tried disabling other non critical plugins so I have the mimumum activated.

    Could you please help resolve.

    Thanks
    Tim

    Attachments:
    You must be logged in to view attached files.
    #3312
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Tim,

    As we aren’t experiencing this issue at our end. We need the admin credentials of your website so that we can look into the issue.

    Kind regards,
    Kriti

    #3315
    Tim WTim W
    Participant
    This reply has been marked as private.
    #3322
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Tim,

    Please provide the admin role to username Kriti.

    Regards,
    Kriti

    #3334
    Tim WTim W
    Participant

    Hi Kriti, I have assigned the admin role.

    Thanks

    Tim

    #3368
    Tim WTim W
    Participant

    Hi Kriti, any update on this item – do you login to check?

    Please note that the import works when importing to the same site that the quiz was exported from but it does not work when trying to import to a differenct site (like my dev site)

    Thanks
    Tim

    #3371
    Kriti SharmaKriti Sharma
    Keymaster

    Thanks for updating me Tim. I will, check it once again.

    Regards,
    Kriti

    #3430
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Tim,

    I just imported a quiz that was created on my staging website on your website. The quiz imported and worked perfectly fine.

    Hope the problem is resolved now. Please check and confirm.

    Regards,
    Kriti

    #3436
    Tim WTim W
    Participant

    Hi Kriti, I can see that there is a new quiz, but the import still does not work for me.

    I updated to the latest version of the plugin also (which I had to do manually because the auto update would not work). But still no success.

    Can you please explain what you did? Perhaps you could send me the file you used to import and I will try and load that same file?

    Thanks

    Tim

    #3437
    Tim WTim W
    Participant

    Hi Kriti,

    I now got this working. I deleted the plugins and reinstalled on both sites, recreated the export file and imported it successfully to the second site.

    Thanks

    Tim

    #3438
    Tim WTim W
    Participant

    Hi Kriti, having been successful with importing a quiz to another site, I did some testing and discovered that when logic is defined in a quiz, the imported version does not properly contain the logic from the original quiz. See the screenshot which shows blank entries.

    Perhaps you could try and replicate in your export / import?

    Thanks

    Tim

    Attachments:
    You must be logged in to view attached files.
    #3455
    Kriti SharmaKriti Sharma
    Keymaster

    Yes, Tim. The Export functionality doesn’t save the logic settings of the quiz. We will try to implement it in the future releases as the feature request. But if you need it on the urgent basis as the custom requirement, please contact our development team at https://justhyre.com/get-a-quote/

    Regards,
    Kriti

    #3461
    Tim WTim W
    Participant

    Hi Kriti,

    In my opinion this is a bug not a feature request, especially as this is a plugin that was already purchased. So the problem should be rectified as soon as possible.

    Would you mind explaining why would you think this is not a bug, given the fact it is a paid for quiz export and import extension?

    Thanks

    Tim

    #3463
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Tim,

    I have forwarded this request to the development team and they will try to implement it soon.

    Regards,
    Kriti

    #3464
    Tim WTim W
    Participant

    Hi Kriti,

    ok thank you.

    Tim

Viewing 15 posts - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.