Skip to content Skip to main navigation Skip to footer

Keep seeing “Please complete all required fields” message

Welcome to QSM Support Forum. Forums QSM Pre-Sales Keep seeing “Please complete all required fields” message

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #4786
    Morten MärcherMorten Märcher
    Participant

    There is a bug where the validation function checks all quizzes on the page and will not let any quiz submit without all required fields being filled in all quizzes on the page. Meaning I see the “Please complete all required fields” message, when I press the start quiz button.

    Just for info then am I running latest version of WordPress + latest version of your plugin.

    Attachments:
    You must be logged in to view attached files.
    #4799
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Morton,

    Please expect a little delay in response as it is weekend. I will get back to you soon.

    Regards,
    Kriti

    #4810
    Morten MärcherMorten Märcher
    Participant

    Sounds great Kriti, will be looking forward to that 🙂

    #4814
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Morten,

    I request you to please share the quizz’s URL so that I can look into the issue.

    Regards,
    Kriti

    #4816
    Morten MärcherMorten Märcher
    Participant

    Just send you a private message, with the info you will need to view the site.

    #4817
    Kriti SharmaKriti Sharma
    Keymaster

    Morten, I haven’t received any private message from your side. Please send it again.

    Regards,
    Kriti

    #4821
    Morten MärcherMorten Märcher
    Participant

    Hi again Kriti,

    Tryed to resend it.

    If you dident got it this time too, can I then send it to your email?

    #4823
    Kriti SharmaKriti Sharma
    Keymaster

    Yes sure, Morten. Please send me the quiz Url at [email protected]

    Kind regards,
    Kriti

    #4831
    Morten MärcherMorten Märcher
    Participant

    Send you an email yesterday evening, hope it got you?

    #4842
    Kriti SharmaKriti Sharma
    Keymaster

    Morten, your email went into my spam folder. I have replied to you via Email. I will get back to you soon .

    Regards,
    Kriti

    #4846
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Morten,

    I visited the page shared by you but as there are multiple quizzes on a single page. May I know on which quiz you are noticing the error so that we can look into the bug and resolve it?

    Kind regards,
    Kriti

    #4850
    Morten MärcherMorten Märcher
    Participant

    Hi Kriti,

    If you take a look at this page “modul-4/” then you can see that it’s a general problem as all quizzes has the same problem with the “Please complete all required fields” message. I have noticed that the problem occurs as soon as you have more then one quiz on a page. If only quiz then no problem.

    #4856
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Morten,

    I just checked all the quizzes of this page from backend. As you have set all the questions to “Required” from Advanced questions settings, that is why it doesn’t let you submit the quiz without answering all the questions. Please disable the “required” setting for all the questions, then you won’t see this message again.

    I have also attached a screenshot with my response.

    Regards,
    Kriti

    Attachments:
    You must be logged in to view attached files.
Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.