Skip to content Skip to main navigation Skip to footer

Save/Resume bugs

Support facility for QSM has been moved to a new location - please use this form.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #4028
    autobots@ankitdesigns.com[email protected]
    Participant

    Hello,

    We purchased the Save/Resume add-on, and we’re running into several bugs with the functionality. Here’s a list:

    1. The ‘Load Quiz’ button shows up even when there’s no quiz to resume (when the user hasn’t taken the quiz yet). Clicking ‘Load Quiz’ then can sometimes result in an infinite load and the Javascript error “front.js?ver=1.0.0:38 Uncaught TypeError: Cannot read property ‘tagName’ of undefined” (see attached screenshot)
    2. When the ‘Load Quiz’ button does resume an in-progress quiz, it starts the user on the first page of the quiz, not the page where they left off.
    3. I’ve seen a dialog box appear prompting the user to resume the quiz, but it’s sporadic and doesn’t always show up. Under what conditions will the dialog box to resume the quiz appear?

    These are some big, functionality-breaking issues that we need working urgently.

    Attachments:
    You must be logged in to view attached files.
    #4030
    autobots@ankitdesigns.com[email protected]
    Participant
    This reply has been marked as private.
    #4077
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Ankit,

    I tried with the credentials you provided, but couldn’t able to. Please share the correct credentials so that we can look into the issue.

    Regards,
    Kriti

    #4098
    autobots@ankitdesigns.com[email protected]
    Participant
    This reply has been marked as private.
    #4164
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Ankit,

    I have forwarded your issue to the development team. I will get back to you as soon as I hear back from them.

    Kind regards,
    Kriti

    #4238
    Tony H.[email protected]
    Participant

    Hi Kriti,

    I’m going to jump in on this thread if that’s okay because I’m experiencing the same issues with the Save and Resume feature.

    I gave my class an exam yesterday (for the college where I work) and the plugin doesn’t remember students’ contact details (First Name, Last Name, Student ID, but no email) or answers entered so far, once the browser has been refreshed. I assume the plugin remembers their IP address(?), User ID or other because the timer remembers how many minutes and seconds they have left.

    So, for example, one student yesterday accidentally closed away his browser during one of his three timed tests created using QSM. However, when he attempted to resume his test and logged in again, the plugin didn’t remember any of his answers; yet it did remember that he only had maybe 10 minutes left (from 60 minutes total). So, he had to take the whole 60-minute test again in just 10 minutes or thereabouts. From my experience, I believe the plugin doesn’t actually save a student’s responses until the ‘Submit’ button is hit at the end, even though the premium version is being used and the Save and Resume feature is both activated with the relevant license key and turned on for each of the three timed tests I created.

    Less of a concern to me but perhaps still worth raising anyway are (1) that the ‘Load Quiz’ button doesn’t appear to serve any purpose since the quiz loads automatically and (2) I don’t think I’ve ever seen a dialogue box saying ‘Resume Quiz’.

    Let me know if you want me to raise this as a separate ticket and/or if you want my premium plugin receipt details, website address and admin details.

    #4239
    Kriti SharmaKriti Sharma
    Keymaster

    Hi [email protected],

    I request you to please raise a separate support ticket for this issue. And also share the website’s admin credentials with me so that our development team can look into the issue.

    Regards,
    Kriti

    #4241
    Tony H.[email protected]
    Participant

    Will do. Thanks, Kriti.

    Cheers

    #4294
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Ankit,

    We have fixed the reported issues in the latest version of Save and Resume addon. Please check and confirm the same.

    Regards,
    Kriti

    #4304
    autobots@ankitdesigns.com[email protected]
    Participant

    Hi Kristi,

    Thank you for getting back to us. Regarding the reported bugs, I’ll address each one line by line for clarity:

    1. The ‘Load Quiz’ button shows up even when there’s no quiz to resume (when the user hasn’t taken the quiz yet). Clicking ‘Load Quiz’ then can sometimes result in an infinite load and the Javascript error “front.js?ver=1.0.0:38 Uncaught TypeError: Cannot read property ‘tagName’ of undefined” (see attached screenshot)
    The Load Quiz button still appears even when there’s no quiz to resume. When there’s no quiz to resume and the button is clicked, we get a different Javascript error now: Uncaught TypeError: Cannot read property 'current_page' of undefined

    2. When the ‘Load Quiz’ button does resume an in-progress quiz, it starts the user on the first page of the quiz, not the page where they left off.
    This has been resolved, thank you!

    3. I’ve seen a dialog box appear prompting the user to resume the quiz, but it’s sporadic and doesn’t always show up. Under what conditions will the dialog box to resume the quiz appear?
    The dialog box does appear to be showing up more consistently now.

    So we’re still experiencing one of the issues mentioned.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.