Skip to content Skip to main navigation Skip to footer

Correct answers being marked as incorrect

Welcome to QSM Support Forum. Forums QSM Pro Support Correct answers being marked as incorrect

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #4031

    Hello, we’ve found a bug where even if the user answers a question correctly, it is still shown as incorrect in the results. This doesn’t happen for all questions, but I’ve tried deleting the question and making it again, and the error still happens. See attached screenshots for the backend and front-end results. We’re using the css class qmn_question_answer_incorrect to style the results as incorrect.

    This may be related to another issue we have, where sometimes saved changes to the quizzes don’t ‘stick’; they sometimes revert back and the work has to be done again. We have some really long quizzes, is it possible there’s an internal limit to the number of quizzes/questions/pages there can be? If not, what else could be causing these issues?

    Attachments:
    You must be logged in to view attached files.
    #4034
    This reply has been marked as private.
    #4037

    Update: We’ve isolated one of the questions having this issue in a separate quiz titled ‘Test Quiz’

    #4038

    Another update: I think invisible characters may be causing the answers to be marked as incorrect. When I rewrite the answers all by hand, they’re marked as correct properly. I’m going to rewrite all the questions where this occurred, but I’ll leave the test quiz up in case you want to see for yourselves. Maybe there’s a way to sanitize for invisible characters

    #4075
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Ankit,

    I tried to login with the credentials you provided, but wasn’t able to do so. Please provide the same so that I can check.

    Regards,
    Kriti

    #4096
    This reply has been marked as private.
    #4162
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Ankit,

    I have forwarded your issue to the development team. But please expect a little delay in resolution as it is the weekend. I will get back to you as soon as I hear back from them.

    Regards,
    Kriti

    #4182
    Kriti SharmaKriti Sharma
    Keymaster

    Hi Ankit,

    We imported your Test quiz onto our staging website.

    https://qsm-stg1.expresstech.dev/quiz/test-quiz/

    It is working properly. QSM is able to detect the correct answer selected and the css classes for the answer provided is correct.

    https://drive.google.com/open?id=1YmgJ4sKxcdApibCVWYKTlklriegXIqBU

    Please update to latest QSM plugin which was released yesterday.

    Please clear any cache plugin’s cache content and browser history after making the update.

    Regards,
    Kriti

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.